Игра работает корректно в Unity, но не работает после билда.

Программирование для iPhone & Android

Игра работает корректно в Unity, но не работает после билда.

Сообщение AlexandrSolovei 09 окт 2017, 17:10

Разрабатываю игру на Android. Решил сделать билд для проверки на телефоне. В Unity все скрипты работают корректно, но после билда, на телефоне, скрипты не работают.
Версия Unity: 5.6.3f1 Personal

Скрины из Unity:
https://imgur.com/3HCuEWP
https://imgur.com/mLTZFz4
https://imgur.com/FyfLeTH
AlexandrSolovei
UNец
 
Сообщения: 2
Зарегистрирован: 09 окт 2017, 16:55

Re: Игра работает корректно в Unity, но не работает после билда.

Сообщение UnitySexyBoys 09 окт 2017, 17:33

Возможно, дело в порядке отрабатывания скриптов (script execution order). Попробуй сбилдить с галкой Development Build.
UnitySexyBoys
UNец
 
Сообщения: 15
Зарегистрирован: 06 окт 2017, 18:11

Re: Игра работает корректно в Unity, но не работает после билда.

Сообщение AlexandrSolovei 09 окт 2017, 17:49

UnitySexyBoys писал(а):Возможно, дело в порядке отрабатывания скриптов (script execution order). Попробуй сбилдить с галкой Development Build.

Не помогло. Как я понял, у меня не работает 1 один скрипт, он отвечает за старт игры (идет проверка: в первый ли раз запускается игра? Выставляются переменные (деньги, энергия и т.д.)). Сам скрипт лежит на Main Camera. Все остальные работают корректно.
https://imgur.com/M77bA4u (Так-же пытался поставить галочку "Script Debugging", но все равно не работает).
AlexandrSolovei
UNец
 
Сообщения: 2
Зарегистрирован: 09 окт 2017, 16:55


Вернуться в iPhone & Android

Кто сейчас на конференции

Сейчас этот форум просматривают: нет зарегистрированных пользователей и гости: 3